git.lirion.de

Of git, get, and gud

summaryrefslogtreecommitdiffstats
path: root/nagios-plugins-contrib-24.20190301~bpo9+1/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'nagios-plugins-contrib-24.20190301~bpo9+1/debian/rules')
-rwxr-xr-xnagios-plugins-contrib-24.20190301~bpo9+1/debian/rules43
1 files changed, 43 insertions, 0 deletions
diff --git a/nagios-plugins-contrib-24.20190301~bpo9+1/debian/rules b/nagios-plugins-contrib-24.20190301~bpo9+1/debian/rules
new file mode 100755
index 0000000..e6c707a
--- /dev/null
+++ b/nagios-plugins-contrib-24.20190301~bpo9+1/debian/rules
@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+PKGNAME = nagios-plugins-contrib
+PLUGINS := $(shell find $(CURDIR) -mindepth 1 -maxdepth 1 -name .git -prune -o -name .pc -prune -o -name debian -prune -o -type d -printf '%f\n' | sort)
+
+%:
+ dh $@ --with quilt,python2
+
+override_dh_auto_build:
+ dh_auto_build
+ $(PACKAGING_HELPER) --generate-readme
+
+PACKAGING_HELPER = /usr/bin/python $(CURDIR)/debian/packaging-helper.py
+
+
+clean: debian/copyright debian/control debian/tests/control
+ dh $@ --with quilt,python2
+ rm -f debian/README.Debian.plugins
+
+CONTROL_FILES := $(shell for p in $(PLUGINS); do echo $$p/control; done)
+COPYRIGHT_FILES := $(shell for p in $(PLUGINS); do echo $$p/copyright; done)
+TESTS_FILES := $(wildcard */tests)
+debian/copyright: debian/copyright.in debian/packaging-helper.py $(CONTROL_FILES) $(COPYRIGHT_FILES)
+ $(PACKAGING_HELPER) --copyright
+ -if [ -d .git ]; then git add $@; git commit -m 'Auto update of $@' $@; fi
+
+debian/control: debian/control.in debian/packaging-helper.py $(CONTROL_FILES)
+ $(PACKAGING_HELPER) --control
+ -if [ -d .git ]; then git add $@; git commit -m 'Auto update of $@' $@; fi
+
+debian/tests/control: debian/packaging-helper.py $(TESTS_FILES)
+ $(PACKAGING_HELPER) --tests
+ -if [ -d .git ]; then git add $@; git commit -m 'Auto update of $@' $@; fi
+
+
+watch:
+ @$(PACKAGING_HELPER) --watch
+
+.PHONY: watch